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SETTINGS, MAKING PDF, TIPS

1 Fonts, settings and plug-ins

1.1 Fonts

The templates may of course use any set of appropriate fonts, but the current
templates are fine-tuned for a set of matching fonts. For this template, you need
to install the following fonts, in addition to the standard fonts in Windows:

o Warnock Pro
o Myriad Pro

These fonts come with the software package Adobe Creative Suite (also in CS2,
but not CS3), so the licensing of the fonts is according to that package. The tem-
plates also use Symbol Std, Courier Std and Adobe Pi, installed by FrameMaker 8 and 9
in its own font directory.

The main reason to use professional fonts rather than standard Windows fonts is
that one can use different weights and variations, thereby achieving a much
smoother result. This makes the reading both easier and nicer. However,
Windows can not handle more that two weights in a single family—regular and
bold. So, in Windows, fonts with many weights and/or variations are treated like
separate font families. But professional authoring software need more power—
FrameMaker can treat all of the font variations as one family with different
weights and variations. To make this happen in FrameMaker, however, fonts
need to be mapped from the Windows style of separate families into common
families, and this mapping is done in a file called maker.ini, see the next
section:

1.2 Font mappings, the .ini file, plug-ins

Make sure to use a properly setup maker.ini file. Since version 7.0 of Frame-
Maker for Windows, a personal copy of maker.ini is created for each user in:
%USERPROFILE%\Application Data\Adobe\FrameMaker\<version>

BragIt has prepared a version of that file, where the most important settings are:
o GetLibraryColorRGBFromCMYK=None
o ClipboardFormatsPriorities
o CopyFileInfoOnImport=off
o DefaultSnapInch and DefaultSnapCm (in practice turning them off )
o DisableAutofitAfterZoom=On (so the zoom 'z' stay in one place)
o Many settings for mapping Windows style fonts into FrameMaker families.
o Font Weights
o Prepared paths for two recommended plug-ins

You should copy the contents into your own maker.ini. The file includes two
paths in the APIClients section for two plug-ins: ABCM (freeware) and
WS_StructureTools (shareware). If you don’t use those plug-ins, you need to
remove/comment those lines, otherwise you need to install those plug-ins.

The ABCM plug-in can use a common settings file that specifies attributes,
colors and filter schemes to be used for Attribute-Based Condition Management
(ABCM) of documents, so that all users in the organization share the same setup.
This file should be installed on a server so that it is reachable by anyone. In the
menu ABCM > Local Preferences... point the Main settings file location (master Copy)
to the file ABCM_MainSettings.fm located on that server.

A BragIt production

http://bragit.com
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2 Making PDF and optimizing it

2.1 Workaround for a cross-reference bug—and optimization

There is a bug in versions of FrameMaker below 9, which has the consequence
that, with the default PDF setup, cross-references in structured documents will
not become PDF hypertext links, unless they also are bookmarks. However, there
is an effective workaround, which also ensures that the final PDF is really small:

In the PDF setup of the book file or the document (Format > Document PDF Setup...),
click on Links and select Create Named Destinations... This will solve the issue, but it will
also bloat the PDF somewhat, which, however, can be remedied in Acrobat Pro-
fessional thus: After the PDF is created, re-save the PDF in Acrobat by Advanced >
PDF Optimizer... while enabling Remove unreferenced named destinations under the Clean Up
section. The result is an even smaller file than without Create Named Destinations...,
and it’s a very general and robust method. For compatibility with older versions
of Adobe Reader, select Acrobat 6.0 and later as the compatibility setting.

2.2 The complete PDF setup

The following is BragIt’s recommended settings in Format > Document PDF Setup... to
get good PDF suitable for on-screen viewing and color or black&white printing:

Settings o PDF Job Options: My Print UnchangedColors. 
This is a Distiller custom settings file stored in:
\Documents and Settings\<user>\Application Data\Adobe\Adobe PDF\Settings\

o Open PDF Document on Page: i at Zoom: Fit Page
o View Generated PDF in Acrobat (must be set in each session, unfortunately)
o No Registration Marks
o Page Size: 210mm x 297mm (8.268" x 11.693")
o Page Range: All
o In FM 9: Convert CMYK Colors to RGB

Bookmarks o Generate PDF Bookmarks, and expand them to level: None or 1, unless 
expanded bookmarks fit on the screen.

o Bookmark source: Paragraphs for books, but Elements for single-file 
documents:
- Paragraphs for single-language book:

- Contents
- Heading1
- .Heading2
- ..Heading3
- Title

- Paragraphs for multilingual book:
- Contents
- .Heading1
- ..Heading2
- ...Heading3
- Subtitle

- Elements for single-file document:
- Appendix
- Chapter
- Preface
- Section(S1)
- Section(S2)
- TableOfContents
- Title

o Articles: Thread by Text Frame

Tags o Do NOT generate Tagged PDF!

Links o In FM <9: Create Named Destinations for All Elements and Paragraphs.
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NOTE In a book, the PDF job options saved with the first file are applied to all files in
the book. Therefore, open the first file in the book and make the settings. The
bookmark level of a paragraph is a property of that paragraph format, so if you
import new paragraph formats, the levels may change accordingly.

Before you generate PDF, make sure that the printer setup in FrameMaker is
Adobe PDF (File > Print Setup...) with the correct paper size, and make sure to
update the book and save all files (including the book file)—saving all files ensure
that you don’t get any “recover” files if FrameMaker crashes during the pdf-pro-
duction. Updating the book file, however, will not refresh the EDD; normally, you
should refresh (reimport) the EDD already during the edit phase of a file; but
make sure that the files really are EDD-refreshed.

2.3 PDF Optimizer

1. Before optimizing the PDF, choose: File > Properties... and set the following:
o In the Initial View tab, tick the setting Resize window to initial page. You may also 

wish to set Page layout to Two-Up (Cover Page) or Single Page.
o In the Advanced tab, choose Page Scaling: None, and Duplex Mode: Duplex Flip Long Edge

2. Advanced > PDF Optimizer... and choose the custom settings file Acrobat 6 print 
stored in: \Documents and Settings\<user>\Application 
Data\Adobe\Acrobat\9.0\Preferences\PDF Optimizer\, which specifies:

Compatibility: Acrobat 6.0 and later

Images o Color: Bicubic to 300 above 450 ppi, JPEG compression, High quality
o Grayscale: Bicubic to 300 above 450 ppi, JPEG compression, High quality
o Monochrome: Bicubic to 600 above 900 ppi, ZIP

Discard Objects o Discard all alternative images
o Convert smooth lines to curves (do not enable this in Acrobat 7)

Discard User Data o Discard hidden layer content and flatten visible layers

Clean Up o All alternatives are ticked (and with Acrobat 9: compress entire file)

2.4 Bookmarks for non-western languages

FrameMaker 8 and later handle Unicode, so bookmarks to destinations that are
in non-western languages should carry over to the PDF without problems. How-
ever, if you use FrameMaker 7.x, bookmarks to destinations that are in non-
western languages will be garbled, since the font used for bookmarks in PDF is a
standard Unicode font, whereas FrameMaker 7.x doesn’t support Unicode. This
can be corrected manually thus: copy the destination heading and paste it into
the corresponding bookmark.

3 Tips

3.1 Pasting Unicode

Text in non-western languages, copied from e.g MS Word, may be in Unicode
format. FrameMaker 8 and later handle full Unicode; therefore, if you use the
setting ClipboardFormatsPriorities in the maker.ini file recommended by BragIt, pasted
text will usually be correct.
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FrameMaker 7.x, however, does not support Unicode, but if you have the right
font, you can paste Unicode text as follows: Make sure you have the right font for
that language. Then do Paste Special... from the Edit menu. Select Rich Text Format.

3.2 Mail link

message URL
mailto:recepient@company.com?Subject=Whatever

3.3 Scale screen shots consistently!

Recommended scaling for screen shots is 150 ppi. 140 ppi may be used if reada-
bility is important. Really small icons may need 120 ppi to be distinct enough.

3.4 Color definitions

If you import 8-bit PNG images into versions of FrameMaker below 9, it will
import all its colours as colour definitions, which will clutter the list. To get rid
of such colour definitions, remove the 8-bit PNG image and save the document as
MIF, and then open the MIF-file. An alternative to 8-bit PNG is 24-bit PNG which
is not plagued by this problem, or use GIF. Transparency in certain 24-bit PNG
images can sometimes cause problems, so I recommend to save 24-bit PNG
images without any transparency.

3.5 Crashes, bloated or corrupted book-file

FrameMaker for Windows has seen a fair number of crashes. Some crashes are
related to making pdf, while generating postscript, probably related to fonts or
font caches (a Windows problem). Fortunately, in contrast to MS Word, Frame-
Maker does not corrupt the files! And, with the exception of the .book file, files
do not bloat and gather junk—they stay slim! What follows are a few hints:

• First of all, make sure that the printer setup in FrameMaker is Adobe PDF! 
(File > Print Setup...)

• Tell the printer Adobe PDF to embed the fonts in the postscript file. This 
has solved some crash situations, at least in FM7. Follow this procedure:
1. Choose Start > Settings > Printers and Faxes.
2. Right-click Adobe PDF, and then choose Properties from the pop-up menu.
3. Choose the tab General, and click Printing Preferences....
4. Choose the tab Adobe PDF Settings, and un-tick:

- in version 7: Do not send fonts to "Adobe PDF"
- in version 8: Rely on system fonts only; do not use document fonts

• Install a “hotfix” by Microsoft: http://support.microsoft.com/?id=952909

• After a crash, some cache files seem to be corrupt, causing FM to crash 
again, even when the original problem is solved! Two methods seem to 
restore these caches, and they can be tried individually or in combination:
o Open a new plain document, for instance “Portrait”, and generate a PDF
o Delete the file: C:\WINDOWS\system32\FNTCACHE.DAT and reboot the computer

• The following simple trick has corrected problems in a few cases: remove a 
file from the .book file, and then add it again!

• The .book file grows after many changes! It can be slimmed by: save it as 
MIF, then open the MIF file and resave it as a normal book file. This has 
eliminated crash problems in at least one instance. (The PDF settings in the 
new file may look as if they have changed, but when actually saving as PDF, 
it will use the PDF job options saved with the first file in the book.)

http://support.microsoft.com/?id=952909
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• In the [WindowsToFrameFontAliases] section in the maker.ini file, it is often 
necessary to specify the variation instead of just an asterisk when they all are 
regular! If not, the fonts may be reported as missing, but even worse: Frame-
Maker may crash when you quit it after having opened either the character 
or paragraph catalogs, and those fonts were used in the document!

3.6 Avoiding printer-resident fonts

If you use any other printer than Adobe PDF, printer-resident fonts (stored in
ROM in the printer) may show up in the list of available fonts. Those fonts are
“phantom fonts” since you can't use them when you convert the document to
pdf, and they cannot even display on your computer. Here’s a procedure to avoid
that. It will also solve a known problem under Windows 2000 and Windows XP
in which characters in the ITC Zapf Dingbats font, one of the “base 35” Post-
Script Type 1 fonts, display in the TrueType WingDings font on the screen.

Technical note: This problem is caused by the fact that the operating system in
conjunction with the driver allows on-host access for formatting purposes to
fonts that are printer-resident, even if they cannot really be accessed or displayed
on your computer because they are not actually installed on your computer!
When you “switch” to the Adobe PDF printer, the fonts seem to “disappear.” Well,
they weren't really there to start with. This “fix” eliminates the “phantom fonts”
and the problems associated with same.

Follow these instructions (originally from http://www.adobeforums.com):

1. Log in as “Administrator” or with a user ID that has administrator privi-
leges. 

2. Make sure no printing is occurring or spooled to any PostScript printer.
3. Go to directory C:\WINNDOWS\system32\spool\drivers\w32x86. 
4. For each .PPD file (except ADPDF7.PPD or ADPDF8.PPD) in directories '2' 

and '3' (in case you have both) do the following a-e:
a Copy the PPD file to a backup location in case you need to subsequently 

retrieve a unmodified version. 
b Open the PPD with an ASCII text editor, such as NotePad.
c Find all lines in the PPD file that begins “*Font”, except “*Font 

Courier:”

d Change the initial “*Font” in each of those lines to “*% Font” (except 
“*Font Courier:”)

e Save the PPD file and exit the text editor. 
5. Delete all the corresponding .BPD files in those directories.

The PostScript driver will then recreate the .BPD files as necessary from the
edited PPD files. 

The procedure effectively tells the driver and operating system to always use the
fonts resident on your computer system as opposed to those which may be ROM
or disk-based in your printing device. 

Remaining annoyance: If you do not have Times installed, FrameMaker will
issue a warning when you switch from a regular printer to Adobe PDF (or just do
save as PDF), where the consol will say that Times is not available and it will use
Times New Roman instead. This happens even if you have not used any Times!
Although harmless, that warning is annoying! Unfortunately, I have not found
any methods to avoid it.

3.7 Set the file information fields!

Don’t forget to set the fields in File > File Info...! Those fields will automatically be
carried over to the PDF.
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